对付楼上最好的办法:炒股公式破解版集锦 C

来源:百度文库 编辑:我要文章网 时间:2019/12/11 13:43:46

稳赚资金

A:MA(CLOSE,32),COLORBLUE,LINETHICK2;B:MA(CLOSE,12),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(B,A),B,'进场'),COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(A,B),A,'走人'),COLORRED,LINETHICK2;
STICKLINE(C>=A,CLOSE,OPEN,3,0),COLOR0000FF;STICKLINE(CSTICKLINE(C>=A,O,H,0,0),COLOR0000FF;STICKLINE(CSTICKLINE(C>=A,C,L,0,0),COLOR0000FF;STICKLINE(C

N:=5;
M:=13;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE进出量:=买量+卖量;
STICKLINE(进出量<0,0,进出量,4,0),COLORFF6600;
STICKLINE(进出量<0,0,进出量,3,0),COLORFF9900;
STICKLINE(进出量<0,0,进出量,1.5,0),COLORFFCC00;
STICKLINE(进出量<0,0,进出量,0.5,0),COLORFFFF00;
STICKLINE(进出量>0,0,进出量,4,0),COLOR000099;
STICKLINE(进出量>0,0,进出量,3,0),COLOR0000CC;
STICKLINE(进出量>0,0,进出量,1.5,0),COLOR0000FF;
STICKLINE(进出量>0,0,进出量,0.5,0),COLORCC66FF;
N日内净流入:SUM(进出量,N),LINETHICK2,COLOR33FF33;
TJ:=进出量>0 AND REF(进出量,1)<0;
连红天:IF(进出量>0,BARSLAST(TJ)+1,0),COLORFF00FF;
M日内翻红天:COUNT(进出量>0,M),COLORRED;
TJ1:=CROSS(0,N日内净流入);
FT:=BARSLAST(TJ1);
走熊天:IF(N日内净流入<0,FT+1,0),COLORFFFF00;
TJ2:=CROSS(N日内净流入,0);
FT2:=BARSLAST(TJ2);
走牛天:IF(N日内净流入>0,FT2+1,0),COLORRED;

短线通道
VAR1:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR16:=EMA(VAR15,13);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR1E:=AMOUNT/VOL/100;
VAR1F:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR28:=(VAR1E-MA(VAR1E,21))/(0.015*AVEDEV(VAR1E,21));
VAR29:=(VAR1F-MA(VAR1F,90))/(0.015*AVEDEV(VAR1F,90));
VAR2A:=((VAR29+VAR28+VAR27+VAR26+VAR20)/5+165)/4;
VAR2B:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2C:=(VAR2A+VAR2B)/2/1.1;
短线: VAR2C, , COLORGREEN;
MID: MA(短线,26), , COLORWHITE;
UPPER: MID+2*STD(短线,26);
LOWER: MID-2*STD(短线,26), , COLORFFFFFF;
IF(短线>MID,MID,短线), , COLORRED;
买点: DRAWICON(CROSS(短线,MID),MID*0.97,1);
DRAWICON(CROSS(短线,LOWER),LOWER*0.97,3);
卖点: DRAWICON(CROSS(UPPER,短线),UPPER*0.97,2);
MID, , COLORYELLOW;


虎口夺食

RSV:=(((C-LLV(L,9))/(HHV(H,9)-LLV(L,9)))*100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3*K)-(2*D));
DIFF:=(EMA(C,12)-EMA(C,26));
DEA:=EMA(DIFF,9);
MACD2:=(2*(DIFF-DEA));
DIF:=DIFF;
MACD:=DEA;
DEF:=MACD2;
CA1:=REF(C,1)>REF(O,1);
CA2:=O>=(REF(C,1)+REF(O,1))/2 AND REF(C,1)>=O;
CA3:=C>(REF(C,1)+REF(O,1))/2;
CA:=CA1 AND CA2 AND CA3;
CB1:=REF(C,1)CB2:=C>O;CB:=CA2 AND CB1 AND CB2;
CC1:=(REF(C,1)+REF(O,1))/2>=O AND O>=REF(C,1);
CC2:=(REF(C,1)+REF(O,1))/2>=C;
CC:=CB1 AND CC1 AND CC2;
CD1:=(REF(C,1)+REF(O,1))/2>=O;
CD2:=O>=C;
CD:=CA1 AND CD1 AND CD2;
CE:=ABS((C-REF(C,1))/REF(C,1)*100)<3;
EB1:=(CA OR CB OR CC OR CD) AND CE;
CF:=BARSLAST(EB1);
EB2:=IF(REF(C,CF)>REF(O,CF),REF(O,CF),REF(C,CF));
EA1:=C>O; EA2:=C-MIN(MIN(REF(C,1),REF(O,1)),O);
EA3:=EA2/ABS(EB2-REF(C,1))*100>50;EA4:=J>REF(J,1);
EA5:=MAX(REF(C,2),REF(O,2))>MIN(O,MIN(REF(C,1),REF(O,1)));
EA6:=(DEF>REF(DEF,1) OR DEF>0) AND (MACD>REF(MACD,1) OR DIF>REF(DIF,1));
艺高胆大者指标:EA1 AND EA3 AND EA4 AND EA5 AND EA6;


狼庄敢死队

N:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1;
VAR2:=8,COLORGREEN,LINETHICK0;
上升在即: IF(CROSS(VAR1,VAR2),50,0),STICK,COLOR0000CC,LINETHICK2;
专吸庄血: IF(VAR1<=8,25,0),STICK,COLORWHITE,LINETHICK2;
DRAWICON(CROSS(VAR1,VAR2),8,5);
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),80,100) ,COLOR00CCFF,LINETHICK1;
{0,LINETHICK2 ,COLORFFCC00;}
DRAWICON(CROSS(100,VAR1),100,6);
DRAWICON((100-VAR1<3 AND 100-VAR1>0),100,6);
DRAWTEXT(CROSS(85,VAR1),85,'▼'),COLORGREEN;
DRAWTEXT(CROSS(VAR1,35),35,'▲'),COLORRED;
DRAWTEXT(CROSS(VAR1,104),104,'◆'),COLORBLUE;
DRAWTEXT(CROSS(VAR1,110) OR CROSS(VAR1,120),115,'○'),COLORWHITE;
强弱分界线:55,COLORLIRED;
Y:=IF((55-VAR1)>=0,-1,1),COLORGREEN;
持股:IF(Y=1,18,DRAWNULL),COLORRED,LINETHICK2;
观望:IF(Y=-1,18,DRAWNULL),COLORGREEN,LINETHICK2;
{以上是专吸庄血,下面的是猎庄敢死队}
B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
B7:IF(B6>60,B6-60,0);
持有:STICKLINE(REF(B7,1){0,POINTDOT,COLORRED,LINETHICK3;};

 


短波趋势

VAR1:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*200-100)/2;
VAR2:=SMA(SMA(VAR1,3,1),3,1);
跟风盘: MA(EMA(VAR2,3),3);
股价趋势: 3*VAR2-2*跟风盘 ;
VAR3:=EMA(CLOSE,13)-EMA(CLOSE,26)*100;
VAR4:=EMA(VAR3,3);
多头能量: 3*(VAR4-VAR3) ;
空头能量: 2*跟风盘-3*VAR2;
STICKLINE(空头能量>0,空头能量,0,0,0) ;
STICKLINE(空头能量<0,空头能量,0,0,0) ;

诱空线

获利盘:WINNER(C)*100,COLORRED;
二十最高:HHV(获利盘,20);
挖坑线:EMA((100+获利盘-二十最高),3),LINETHICK2;
成本乖离:(C/COST(50)-1)*100;

 

买卖指标

VAR1:=REF(CLOSE,2);
A2: SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100, , COLOR00FF00;
超卖1: IF(A2<12,30,0),COLORF00FF0;
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;
超卖2: IF(VAR3<12,30,0),COLORYELLOW;
逢高派发区: STICKLINE(A2>80,A2+1,A2-1,8,0), , COLORRED;
我走了: IF(A2< REF(A2,1) AND A2>79,A2,0),COLORGRAY;

 

极品DDx

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE进出量:=买量+卖量,COLOR00FFFF;

 

STICKLINE(进出量<0,0,进出量,4,0),COLORFF6600;
STICKLINE(进出量<0,0,进出量,3,0),COLORFF9900;
STICKLINE(进出量<0,0,进出量,1.5,0),COLORFFCC00;
STICKLINE(进出量<0,0,进出量,0.5,0),COLORCYAN;
STICKLINE(进出量>0,0,进出量,4,0),COLOR000099;
STICKLINE(进出量>0,0,进出量,3,0),COLOR0000CC;
STICKLINE(进出量>0,0,进出量,1.5,0),COLOR0000FF;
STICKLINE(进出量>0,0,进出量,0.5,0),COLORCC66FF;

N:=5;
M:=13;
N日内净流入:SUM(进出量,N),LINETHICK2,COLORGREEN;
流入:IF(N日内净流入>REF(N日内净流入,1),N日内净流入,DRAWNULL),COLORRED,LINETHICK2;
连红天:BARSLASTCOUNT(进出量>0);
M日内翻红天:COUNT(进出量>0,M),COLORRED;


走熊天:BARSLASTCOUNT(N日内净流入<0),COLORCYAN;
走牛天:BARSLASTCOUNT(N日内净流入>0),COLORRED;
强势天:BARSLASTCOUNT((N日内净流入>REF(N日内净流入,1))>0 AND
N日内净流入>0);
弱势天:BARSLASTCOUNT((N日内净流入0 AND
N日内净流入<0);


突破盘整

W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
突破盘整:W4 AND COUNT(W4,5)=1;

主力轨迹

RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
Y0:SMA(RSV,3,1),COLORRED,LINETHICK1;
Y1:SMA(Y0,3,1),COLORYELLOW,LINETHICK1;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
Y2:SMA(RSV1,5,1),COLORMAGENTA,LINETHICK2;
Y3:SMA(Y2,10,1),COLORGREEN,LINETHICK2;
超卖:18,COLORWHITE;
超买:85,COLORBLUE;
STICKLINE(Y0>Y1,Y0,Y1,1,0),COLORRED;
STICKLINE(Y0<=Y1,Y0,Y1,1,0),COLORYELLOW;
STICKLINE(Y2>Y3,Y2,Y3,1,0),COLORMAGENTA;
STICKLINE(Y2<=Y3,Y2,Y3,1,0),COLORGREEN;

波段赢家(主图叠加)

获利了结:EMA(EMA(EMA(HIGH,5),5),5)*1.15,COLORFFFFFF,LINETHICK1;
风险: EMA(EMA(EMA(HIGH,5),5),5)*1.1,COLORYELLOW;
回档: EMA(EMA(EMA(HIGH,5),5),5)*1.05,COLOR00FF00;
平衡: EMA(EMA(EMA(HIGH,5),5),5),COLORFF00FF,LINETHICK1;
反弹: EMA(EMA(EMA(HIGH,5),5),5)*0.95,COLORGRAY,LINETHICK1;
超跌: EMA(EMA(EMA(HIGH,5),5),5)*0.9,COLORBLUE,LINETHICK1;

买卖天机

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交量:VOL,LINETHICK0;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSESTICKLINE(VOL>0,VOL,0,2,1),COLORWHITE;
STICKLINE(主动买盘>0,0,主动买盘,2,0),COLORRED;
STICKLINE(主动卖盘<0,0,主动卖盘,2,0),COLORGREEN;

莉莉主图

短线BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORGREEN,LINETHICK2;
长线EBBI:(EMA(C,6)+EMA(C,18)+EMA(C,54)+EMA(C,162))/4,COLOR0000FF,LINETHICK2;
STICKLINE(CROSS(短线BBI,长线EBBI),L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(CROSS(短线BBI,长线EBBI),L-0.13,'走牛') ,COLORYELLOW;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,O,3,1),COLORRED;{红1}
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,H,H,0,0),COLORRED;{红1};
VARD:=CLOSEVARE:=REF(VARD,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,O,3,0),COLORFFCC66;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,H,L,0,0),COLORFFCC66;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,1),COLORYELLOW;
{VAR19;}
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,H,O,4,2),COLORWHITE{98FD};
AAF:LLV(LOW,34),LINETHICK1,COLORWHITE;
BBF:IF(VAR19>0,MA(AAF,4)*1.06,MA(AAF,4)),LINETHICK1,COLORFFAAFF;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
DRAWICON(CROSS(RSI,11) ,L*0.99,1);
VAR27:=REF(CLOSE,1);
VAR28:=SMA(MAX(CLOSE-VAR27,0),5.5,1)/SMA(ABS(CLOSE-VAR27),6,1)*100;
DRAWICON((IF(CROSS(76,VAR28),1,0)) OR CROSS(84,RSI),H*1.03,2);
DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)>0 AND EMA(CLOSE,12)/LOW>1.15,5),LOW,'☆'),LINETHICK3 ;
VARA1:=((AMOUNT)/(VOL))/(100);
VARB1:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC1:=((SUM(AMOUNT,7))/(VARA1))/(100);
VARD1:=DMA(VARB1,(VOL)/(VARC1));
VARE1:=((CLOSE-VARD1)/(VARD1))*(100);
VARF1:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ1:=MA(VARE1,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
AA:=SMA(VARF1,3,1);
SS:=(REF(BIAS18,1)>=5) AND CROSS(VARJ1,VARE1) AND (AA>79);
DRAWTEXT(REF(BIAS18,1)>=5 AND CROSS(VARJ1,VARE1) AND AA>SS,H*1.02,'☆'),LINETHICK3,COLORGREEN;

短线买卖

SS:=IF(YEAR>2008 ,0,1);
AAA:=(MA(CLOSE,13)+MA(CLOSE,17))/2*SS;
CCC:=(STD(CLOSE,13)+STD(CLOSE,17))/2*SS;
BBB:=AAA+2.1*CCC*SS;
DDD:=AAA+0.72*CCC*SS;
ZZZ:=IF(CCC>1.88 ,MA(DDD,3),DDD)*SS;
AA:=ZZZ*SS;
BB:=ZZZ*1.1*SS;
CC:=ZZZ*1.05*SS;
DD:=ZZZ*0.95*SS;
EE:=ZZZ*0.9*SS;
短线买卖: (C-EE)/(BB-EE)*100*SS;
平衡线:MA(短线买卖,13)*SS;
天线:100;
地线:0;

波段之星

VAR2:=(HIGH+LOW+CLOSE*2)/4;
VAR3:=EMA(VAR2,21);
VAR4:=STD(VAR2,21);
VAR5:=((VAR2-VAR3)/VAR4*100+200)/4;
VAR6:=(EMA(VAR5,5)-25)*1.56;
AK: EMA(VAR6,2)*1.22;
AD: EMA(AK,2);
AJ: 3*AK-2*AD;
100, POINTDOT;
0, POINTDOT;
80, POINTDOT;
买进: IF(CROSS(AK,AD),58,20);
卖出: IF(CROSS(AD,AK),58,20);

短线精灵

VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR2:=LLV(LOW,21);
VAR3:=HHV(HIGH,21);
SK: EMA((VAR1-VAR2)/(VAR3-VAR2)*100,5);
SD: EMA(0.667*REF(SK,1)+0.333*SK,4);
VAR4:=IF(CROSS(SD,SK) AND SK>=60,60,76);
VAR5:=IF(CROSS(SK,20) OR CROSS(SK,SD) AND SK>20,20,5);
买进: VAR5;
卖出: VAR4;
高抛: 80, POINTDOT;
低吸: 20, POINTDOT;
强弱: 50, POINTDOT;
VAR6:=LLV(LOW,55);
VAR7:=HHV(HIGH,34);
VAR8:=EMA((VAR1-VAR6)/(VAR7-VAR6)*100,3);
VAR9:=(SK+VAR8)/2;
VARA:=EMA(0.667*REF(VAR8,1)+0.333*SK,2);
VARB:=EMA(VAR9,5);
VARC:=EMA(0.667*REF(VARB,1)+0.333*VARB,2);
IF(VARB>=40,20,0);


主力进出

VAR1:=(CLOSE*2+HIGH+LOW)/4;
VAR2:=EMA(VAR1,13)-EMA(VAR1,34);
VAR3:=EMA(VAR2,5);
强弱分界: 0, CIRCLEDOT;
空方主力: (-2)*(VAR2-VAR3)*3.8, LINESTICK;
多方主力: 2*(VAR2-VAR3)*3.8, LINESTICK;

短线快枪

{短线快枪手}
A01:=(C-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3));
A11:=SMA(A01,2,1);
A21:=SMA(A11,2,1);
A31:=3*A11-2*A21 ;
A41:=2*A31-0.5;
生命线:C*(1-(A41-A21)/15),COLORF5CCEB,LINETHICK2;
弱: IF(MA(CLOSE,4)>SMA(LOW,21,2)*1.01,SMA(LOW,21,2)*1.01,SMA(LOW,21,2)*1.01),COLORCYAN,COLORYELLOW;
强:IF(SMA(LOW,21,2)*1.01>=REF(SMA(LOW,21,2)*1.01,1),SMA(LOW,21,2)*1.01,DRAWNULL),LINETHICK1,COLORMAGENTA;
DRAWTEXT(CROSS(C,IF(MA(CLOSE,4)>SMA(LOW,21,2)*1.01,SMA(LOW,21,2)*1.01,SMA(LOW,21,2)*1.01)),LOW,'△'),COLORYELLOW;
DRAWTEXT(CROSS(C,生命线),LOW,'△'),COLORGREEN;
DRAWTEXT(FILTER(EMA(EMA(C,5),5)>REF(EMA(EMA(C,5),5),1)AND HHV(MA(H,13),13)REF(C,1),11),L*0.98,'追涨'),COLORGREEN;
DRAWTEXT(CROSS(84,SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100),H*1.03,'逃顶'),COLORYELLOW ;
阻力: PEAK(1,5,1),COLOR66CC00;
支撑: TROUGH(2,5,1),COLORFFB97A;

买了不输

A1:=AMOUNT/VOL/1000;
B2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
D3:=SUM(AMOUNT,13)/A1/1000;
E4:=DMA(B2,VOL/D3);
买了不输:(CLOSE-E4)/E4*1000;
VARX:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARX1:=SMA(VARX,3,1);
VARX2:=SMA(VARX1,3,1);
VARX3:=REF(LOW,1);
VARX4:=SMA(ABS(LOW-VARX3),3,1)/SMA(MAX(LOW-VARX3,0),3,1)*100;
VARX5:=EMA(IF(CLOSE*1.2,VARX4*10,VARX4/10),3);
VARX6:=LLV(LOW,30);
VARX7:=HHV(VARX5,30);
VARX8:=IF(LLV(LOW,58),1,0);
VARX9:=(EMA(IF(LOW<=VARX6,(VARX5+VARX7*2)/2,0),3)/618*VARX8);
-88,COLORYELLOW,POINTDOT;
STICKLINE(VARX9>VARX2,买了不输-15,买了不输+30,2,1),COLORGREEN ;
STICKLINE(CROSS(买了不输,-166),-200,60,4,0),COLORCYAN ;
STICKLINE(CROSS(买了不输,-120),-180,50,4,0),COLORBLUE ;
STICKLINE(CROSS(买了不输,-88),-140,20,4,0),COLORGREEN ;
DRAWTEXT(CROSS(买了不输,-166),-160,'★:极低'),COLORCYAN;
DRAWTEXT(CROSS(买了不输,-120),-80,'★:较低'),COLORBLUE;
DRAWTEXT(CROSS(买了不输,-88),0,'★:稍低'),COLORGREEN;

短线黑马

{短线黑马}
VAR6:=((((2 * CLOSE) + HIGH) + LOW) / 4);
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((((VAR6 - VAR7) / (VAR8 - VAR7)) * 100),13);
VARA:=EMA(((0.667 * REF(VAR9,1)) + (0.333 * VAR9)),2);
多:VAR9,POINTDOT,COLORFF00FF;
空:EMA(((0.382 * REF(VAR9,2)) + (0.618 * VAR9)),12),COLORFFCC66;
STICKLINE((VAR9 > VARA),VAR9,VARA,4,0);
STICKLINE((VAR9 <= VARA),VAR9,VARA,4,0);
黑马一:IF(((((VOL / 120) > (MA(VOL,5) / 120)) AND (CLOSE > (OPEN * (1 + (4.8 / 100))))) AND (CLOSE < (MA(CLOSE,30) * 1.6))),40,0),COLORWHITE,POINTDOT;
STICKLINE( 黑马一,40,0 ,1,1 ),COLORWHITE;
VAR1:=IF(((MA(VOL,5) / 120) AND (CLOSE > (REF(CLOSE,1) * 1))),8,0);
VAR2:=IF(((((((CLOSE / REF(CLOSE,1)) >= 1.05) AND (((VOL / CAPITAL) * 100) < 10)) AND (CLOSE < 18)) AND ((HIGH / CLOSE) < 1.01)) AND (VAR1 > 0)),10,0);
VAR3:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR4:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);
FNZH:=((VAR4 < (0 - 50)) AND (VAR3 > 7));
黑马二:IF(((VAR2 > 9) OR FNZH),35,0),COLORFF00FF,POINTDOT;
STICKLINE(黑马二 ,35 ,0 ,1, 1),COLORFF00FF;
AR1:=IF((((CLOSE AND (MA(VOL,5) / 120)) AND (CLOSE > (REF(CLOSE,1) * 1))) AND CLOSE),88,0);
VARR:=IF(((((((CLOSE / REF(CLOSE,1)) > 1.05) AND (((VOL / CAPITAL) * 100) < 10)) AND (CLOSE < 17)) AND ((HIGH / CLOSE) < 1.01)) AND (VAR1 > 0)),91,0);
黑马三:IF((VARR > 90),30,0),COLORFFCC66,POINTDOT;
STICKLINE(黑马三 ,30, 0,1,1 ),COLORFFCC66;

 


预测明天

{BZ-预测明天(主图)-----------------<<预测明天公式>> 通达信修改版}
P1:=5;
P2:=10;
P3:=20;
P4:=30;
P5:=60;
P6:=120;
P7:=240;
P8:=340;
N:=4;
WX:=MA(CLOSE,0);
M1:=MA(CLOSE,P1);
M2:=(MA(CLOSE,P2) * IF((N < 2),WX,1));
M3:=(MA(CLOSE,P3) * IF((N < 3),WX,1));
M4:=(MA(CLOSE,P4) * IF((N < 4),WX,1));
M5:=(MA(CLOSE,P5) * IF((N < 5),WX,1));
M6:=(MA(CLOSE,P6) * IF((N < 6),WX,1));
M7:=(MA(CLOSE,P7) * IF((N < 7),WX,1));
M8:=(MA(CLOSE,P8) * IF((N < 8),WX,1));
C1:=REF(CLOSE,1);
C2:=HHV(C1,2);
C3:=LLV(C1,1);
ET:=HHV(C1,2);
ET1:=REF(ET,1);
XB:=LLV(C1,1);
XB1:=REF(XB,1);
M:=BARSLAST(((CLOSE < XB) AND (C1 >= XB1)));
M11:=REF(M,1);
N9:=BARSLAST(((CLOSE > ET) AND (C1 <= ET1)));
N1:=REF(N9,1);
M21:=(BARSLAST((((M - N9) > 0) AND (M11 <= N1))) + 1);
N2:=(BARSLAST((((N9 - M) > 0) AND (N1 <= M11))) + 1);
ET2:=HHV(ET,M21);
XB2:=LLV(XB,N2);
A:=IF((((M - N9) > 0) AND (M11 <= N1)),1,IF((((N9 - M) > 0) AND (N1 <= M11)),0,2));
H1:=IF(((M - N9) > 0),CLOSE,ET2);
H2:=IF((A = 1),CLOSE,C2);
H3:=IF(((M - N9) < 0),CLOSE,XB2);
H4:=IF((A = 1),CLOSE,XB2);
H5:=IF((((M - N9) > 0) OR (A = 1)),CLOSE,H3);
H6:=REF(H5,1);
H7:=REF(H5,2);
H8:=(H5 > H6);
H9:=(((H4 = REF(H4,1)) AND (REF(H4,1) < REF(H4,2))) AND (H5 > REF(H5,2)));
H10:=(((H2 = REF(H2,1)) AND (H4 = REF(H4,1))) AND (H5 = REF(H5,2)));
W:=((H8 OR H9) OR H10);
T9:=((H5 < H6) AND (H5 < REF(H5,2)));
T10:=((H4 = REF(H4,1)) AND (H5 < REF(H5,2)));
T11:=((H3 > REF(H3,1)) AND (H5 < REF(H5,1)));
T12:=((H5 = REF(H5,1)) AND (H3 = H4));
T13:=((H2 = REF(H2,1)) AND (H2 = H5));
TW:=((((T9 OR T10) OR T11) OR T12) OR T13);
PK:=((AMOUNT * (((OPEN + CLOSE) + HIGH) + LOW)) / 4);
PK1:=IF((VOL > 0),(PK / AMOUNT),((((OPEN + CLOSE) + HIGH) + LOW) / 4));
BBP:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);

STICKLINE((ISLASTBAR AND W),(H5 * 1.025),(H5 * 0.99),0.5,0),COLORFF8800;
STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,8,0),COLOR102088;
STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,7,0),COLOR102099;
STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,6,0),COLOR1020AA;
STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,5,0),COLOR1020BB;
STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,4,0),COLOR1020CC;
STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,3,0),COLOR1020DD;
STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,2,0),COLOR1020EE;
STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,1,0),COLOR1020FF;
DRAWTEXT((ISLASTBAR AND (BBP >= 96.5)),(H5 * 1.022),'明见\N 短高\N 龙头\N 除外'),COLORRED;
DRAWTEXT((ISLASTBAR AND (BBP < 1)),((H5 + H4) / 1.96),'明见\N 短低\N 跌停\N 除外'),COLORGREEN;
DRAWTEXT(((ISLASTBAR AND W) AND (BBP < 96.5)),(H5 * 1.022),'明日\N 看涨'),COLORYELLOW;
DRAWTEXT(((ISLASTBAR AND TW) AND (BBP > 1)),((H5 + H4) / 2),'明日\N 看跌'),COLORGREEN;

专家理财

{理财专家}

{参数 D:34,90,72}

VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VAR1);
VAR3:=100-3*SMA((CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1),15,1);
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,89))/(0.015*AVEDEV(VAR5,89));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34))*100,20,1)-2*SMA(SMA
((INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,75))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA
((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=VAR11-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;
VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<22 AND VAR15<28 AND VAR16>50,80,0);
活筹OAMV: VAR3,COLORFF00FF;
OX: IF(VARB<90,VARB,100),COLORFFCC66;
VAR21:=IF(VAR1>0,VAR1,0);
核能: IF(VAR1<0,VAR2,0), LINESTICK;
牛角: VAR20,COLORYELLOW;
预警: IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))
+60,COLOR00FF00;
VAR22:=100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34));
VAR23:=MA(VAR22,3);
VAR24:=EMA(AMOUNT/VOL/100,5);
VAR25:=EMA(AMOUNT/VOL/100,13);
VAR26:=VAR24-VAR25;
势能: IF(1000*VAR26/VAR24>0,1000*VAR26/VAR24,0),COLORRED,LINETHICK2;
STICKLINE(VAR3>=REF(VAR4,1),VAR3,VAR4,8,1),COLORRED;
STICKLINE(VAR3VAR27:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
VAR28:=CLOSEVAR29:=VAR21>50 AND 预警>60 AND OX=100;
VAR2A:=VAR21>48 AND 预警>60 AND OX<100;
VAR2B:=核能>38 AND 预警<55;
VAR2C:=牛角>50 AND OX<90;
VAR2D:=VAR3REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR2E:=VAR3>=REF(VAR4,1) AND CLOSE=REF(核能,1) AND VARCDRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,90,'持股待涨'),COLORFF00FF;
DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,10,'出局为佳'),COLOR00FF00;
DRAWTEXT(VAR29 AND COUNT(VAR29,30)=1,70,'上涨过急,需要调整'),COLORWHITE;
DRAWTEXT(VAR2A AND COUNT(VAR2A,30)=1,80,'拉升在即狂牛!'),COLORYELLOW;
DRAWTEXT(VAR2B AND COUNT(VAR2B,30)=1,20,'不必杀跌有反弹 '),COLORWHITE;
DRAWTEXT(VAR2C AND COUNT(VAR2C,30)=1,30,'角斗士,阶段底部 '),COLORYELLOW;
DRAWTEXT(VAR2D AND COUNT(VAR2D,30)=1,60,'大资金进场'),COLOR0099FF;
DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,40,'高点回落'),COLORFFCC66;


极品金叉

DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;
DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;

招财猫

{招财猫买}
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
选股:CROSS(C,ZX) AND VOL>0;

短线之王

VAR1:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));
CROSS(VAR1,-87) AND OPEN=1.099*REF(CLOSE,1) AND INDEXC>0.98*REF(INDEXC,1) AND CLOSE<=1.47*LLV(CLOSE,58);

 


疯牛选股

VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(V>0,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),2,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),2);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
绝佳买点:=IF(V>0,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),2),100000000);
I:=IF(CLOSE骤雨初晴:= ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);

IF(CROSS(绝佳买点,24000),15,0 ) ;